Weekly roundup
Open-source business platforms week 44 2026: unauthenticated SQL injection and code execution lead 39 advisories
Open-source business platforms week 44 2026 lists 39 vulnerabilities, 16 with CVE ids. Key issues: critical Frappe path-traversal RCE, unauthenticated GLPI SQL injection, WordPress Core upgrade-window RCE with no fix. No KEV-listed or exploited flaws. Patch Frappe, GLPI and Dolibarr first.
The release at a glance
In the week of 26 October to 1 November 2026, the maintainers of WordPress, GLPI, Nextcloud, Moodle, Frappe/ERPNext, Dolibarr and Drupal published 39 vulnerability advisories, 16 of them with a CVE id and 23 as GitHub security advisories. Severity breaks down as one critical, 17 high, 7 medium and 14 unscored. None is listed in CISA KEV, and none is flagged as exploited in the public advisories.
WordPress accounts for 12 of the advisories, GLPI for 10, Nextcloud and Moodle for 4 each, and Frappe/ERPNext, Dolibarr and Drupal for 3 each. The most immediate items are the critical Frappe path-traversal RCE, an unauthenticated SQL injection in GLPI, and a WordPress Core staged-installer RCE for which no fixed version is stated. Dolibarr also fixes an OS command injection.
What matters most
Frappe/ERPNext — CVE-2026-119145 is a critical path traversal in file upload (CVSS 4.0 9.4). An authenticated attacker can write files outside the intended storage directory and achieve remote code execution. CVE-2026-119144 is server-side template injection in message fields (8.7); an authenticated user with a common operational role can inject template expressions evaluated in an unrestricted context. Both CVEs have their own pages on this site.
GLPI — GHSA-753w-2942-4pxm is an unauthenticated, time-based SQL injection in the planning feature (8.7), fixed in 11.0.9. GHSA-hv93-qr6v-7mpj is a race condition that can allow installation of a malicious plugin archive (8.9), fixed in 10.0.27 or 11.0.9. Other high-severity GLPI advisories cover stored XSS in ticket actors, asset names and network equipment models, MFA bypass via password reset, arbitrary file deletion and malicious upload; most are fixed in 11.0.9, with some also fixed in 10.0.27.
Dolibarr — CVE-2026-116219 is OS command injection via the mysqldump parameter in htdocs/admin/tools/export.php (8.6). An authenticated administrator can chain commands with & around an allowlisted basename to execute commands as the web server user; fixed in 24.0.0. This CVE has its own page on this site.
WordPress — CVE-2026-119977 is an unauthenticated staged-installer remote code execution during the full-package core upgrade window (8.1). Its published title lists affected versions 4.7.0 through 7.1.3, and no fixed version is given. This CVE has its own page on this site.
Patch in this order
- Patch Frappe first. CVE-2026-119145 is critical and fixed in Frappe 15.121.0 and 16.34.0; CVE-2026-119144 is fixed in Frappe 15.111.0 and 16.21.0. Apply the appropriate update for your installation.
- Patch GLPI. GLPI 11.0.9 fixes the unauthenticated SQL injection, MFA bypass and stored XSS advisories in this release. GLPI 10.0.27 is listed for the race condition, arbitrary file deletion and malicious upload advisories; apply the update that matches your installation.
- Patch Dolibarr to 24.0.0 to address CVE-2026-116219.
- Treat WordPress Core CVE-2026-119977 separately: no patch is available and no workaround is stated. Monitor WordPress release channels for a fix.
- Then apply the remaining medium and unscored updates for Moodle, Drupal, Nextcloud and the other WordPress advisories as the maintainers publish fixes.
Beyond the patch
Most of this week's serious flaws are injection and arbitrary code execution issues, which a penetration test and hardening review surface before they become operational risk. Our Implementation & Assessment Services test for injection, deserialisation and authentication weaknesses like these. Because successful exploitation of the critical Frappe, GLPI or Dolibarr issues would leave post-exploitation activity, Managed Detection & Response is the safety net for code execution and credential abuse until patches are applied.
Every advisory in this release
| ID | Product | Severity | |
|---|---|---|---|
| CVE-2026-119145 | frappe | Critical 9.4 | Advisory → |
| CVE-2026-119144 | frappe | High 8.7 | Advisory → |
| GHSA-hv93-qr6v-7mpj | GLPI | High 8.9 | |
| GHSA-753w-2942-4pxm | GLPI | High 8.7 | |
| CVE-2026-116219 | dolibarr | High 8.6 | Advisory → |
| GHSA-3rr2-mxv6-rmc2 | GLPI | High 8.6 | |
| CVE-2026-119977 | WordPress | High 8.1 | Advisory → |
| GHSA-wrcp-j8fp-pfvx | GLPI | High 8.5 | |
| GHSA-75jp-p2vm-9vmh | GLPI | High 8.5 | |
| GHSA-7x93-gxc8-jp8m | GLPI | High 8.5 | |
| GHSA-m9x5-44w4-jj4g | GLPI | High 8.4 | |
| GHSA-pr87-h373-xr6c | GLPI | High 8.3 | |
| GHSA-g7r2-v98g-6wcr | ERPNext | High 7.7 | |
| GHSA-rvrc-4jr9-wm5c | GLPI | High 7.7 | |
| CVE-2026-77167 | server | High 7.5 | |
| GHSA-5jg3-2qx2-gq7g | GLPI | High 7.5 | |
| CVE-2026-119553 | moodle | High 7.1 | |
| CVE-2026-116218 | dolibarr | High 7.2 | |
| CVE-2026-118754 | Dolibarr ERP/CRM | Medium 6.9 | |
| CVE-2026-119554 | moodle | Medium 6.0 | |
| CVE-2026-119555 | moodle | Medium 5.3 | |
| CVE-2026-119556 | moodle | Medium 5.3 | |
| CVE-2026-77172 | Server | Medium 5.3 | |
| GHSA-6m4h-j3wr-v388 | Server | Medium 5.3 | |
| CVE-2026-82984 | Server | Medium 4.3 | |
| CVE-2026-108514 | Drupal core | Not scored | |
| CVE-2026-108515 | Drupal core | Not scored | |
| CVE-2026-108097 | Drupal core | Not scored | |
| GHSA-83c2-c4pc-wmp3 | WordPress | Not scored | |
| GHSA-2p22-wv7j-cvfv | WordPress | Not scored | |
| GHSA-7q86-3j97-744j | WordPress | Not scored | |
| GHSA-wjwj-p342-9fq7 | WordPress | Not scored | |
| GHSA-j255-3x8q-7q7g | WordPress | Not scored | |
| GHSA-9vrg-x932-q57q | WordPress | Not scored | |
| GHSA-j3rg-rwgx-7wx7 | WordPress | Not scored | |
| GHSA-mqjw-vvgg-xfvf | WordPress | Not scored | |
| GHSA-vchg-92fx-636p | WordPress | Not scored | |
| GHSA-p2r6-rwjp-phv3 | WordPress | Not scored | |
| GHSA-4w3m-c66w-69mg | WordPress | Not scored |
References
Vendor advisory
- GitHub Security Advisory (GHSA-9pp9-wgp9-3p3j)
- Possibility of Server Side Template Injection
- Race condition in marketplace allowing malicious plugin installation
- Unauthenticated SQL injection in planning feature
- Dolibarr fix (GitHub)
- MFA bypass via password reset
- Stored XSS in network equipement models
- Stored XSS in ticket actors
Other
- VulnCheck Advisory: Frappe before 15.121.0 and 16.x before 16.34.0 Path Traversal RCE v…
- VulnCheck Advisory: Frappe Framework before 15.111.0 and 16.x before 16.21.0 Server-Sid…
- github.com/Dolibarr/dolibarr/blob/23.0.3/htdocs/admin/tools/export.php#L129-L154
- github.com/Dolibarr/dolibarr/blob/23.0.3/htdocs/core/class/utils.class.php#L322-L327
- github.com/Dolibarr/dolibarr
- VulnCheck Advisory: Dolibarr ERP CRM before 24.0.0 OS Command Injection via mysqldump P…
- www.wordfence.com/threat-intel/vulnerabilities/id/4b4da0cf-d9f4-47c4-a0e8-6c4dc5a6f250?…
- core.trac.wordpress.org/browser/tags/7.1.3/src/wp-admin/includes/class-wp-upgrader.php#…
CVE / GHSA
- CVE-2026-119145 — cve.org
- CVE-2026-119145 — NVD
- EUVD-2026-113212 — ENISA EUVD
- CVE-2026-119144 — cve.org
- CVE-2026-119144 — NVD
- EUVD-2026-113211 — ENISA EUVD
- GHSA-hv93-qr6v-7mpj — GitHub
- GHSA-753w-2942-4pxm — GitHub
- CVE-2026-116219 — cve.org
- CVE-2026-116219 — NVD
- EUVD-2026-109811 — ENISA EUVD
- GHSA-3rr2-mxv6-rmc2 — GitHub
- CVE-2026-119977 — cve.org
- CVE-2026-119977 — NVD
- EUVD-2026-114575 — ENISA EUVD
- GHSA-wrcp-j8fp-pfvx — GitHub
- GHSA-75jp-p2vm-9vmh — GitHub
- GHSA-7x93-gxc8-jp8m — GitHub
- GHSA-m9x5-44w4-jj4g — GitHub
- GHSA-pr87-h373-xr6c — GitHub